Incompatible avec macOS Sierra ?

Pour discuter en français des sujets concernant Négatron ou MAME, ça se passe ici !
Post Reply
Nigol
Posts: 1
Joined: Sun May 28, 2017 9:05 pm

Incompatible avec macOS Sierra ?

Post by Nigol » Sun May 28, 2017 9:11 pm

Bonjour,
Lorsque je double-clique sur Negatron.command, le terminal s'ouvre et s'arrête sur le message d'erreur suivant (macOS Sierra 10.12.5, Java 1.8.0_131) :

Exception in thread "main" java.lang.UnsupportedClassVersionError: net/babelsoft/negatron/NegatronApp : Unsupported major.minor version 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

Merci de votre aide.

BabelSoft
Site Admin
Posts: 298
Joined: Sat Jun 02, 2012 9:23 pm

Re: Incompatible avec macOS Sierra ?

Post by BabelSoft » Mon May 29, 2017 6:54 pm

Ce message d'erreur indique que vous avez lancé Négatron avec une vieille version de Java. La version 52.0 indique la version du format des fichiers Java, 52.0 veut simplement dire que j'ai compilé Négatron avec Java 1.8. Si cette erreur a été levée, c'est qu'il y a une plus vieille version de Java dans votre système et que Négatron a été lancé avec.

Il y a 2 solutions:
- forcer le démarrage de Négatron avec Java 1.8.0_131,
- mettre Java 1.8.0_131 comme la version par défaut à la place de la plus vieille version.

Pour éviter ce genre d'erreurs sous Windows, j'ai fait un pack spécial Windows qui contient d'office la bonne version de Java. Je sais qu'il est possible de faire quelque chose de similaire pour Mac mais je n'ai pas de Mac, donc je ne peux pas tester pour voir comment faire. J'avais fait des tests il y a 1 an en empruntant le MacBook d'un ami...

Post Reply