Page 1 of 1


Posted: Fri Aug 10, 2018 10:14 pm
by BradYonder

Not a bug per se but something to consider either in instructions or perhaps a fix is in order:

If there are any spaces in the path names for your directories (MAME, Extras, and Multimedia), Negatron will crash and tell you to edit the Negatron.ini file or delete it so it can be re-created next time it runs; however, if you still have spaces in your path names, the process will keep repeating itself.

Possible Solutions:

1) Replace spaces with underscores. For example, replace
c:\mystuff\MAME 0.200\mame.exe with

(I did this and it worked just fine)

2) Not sure if an option (hence possible fix) but have quotations around path names of directories in Negatron.ini file. I personally don't know if this will work (I went with option 1 above) and it may be cumbersome to have to change each time the directories change, if ever, but if Negatron would include them from the start, it would alleviate having to replace the spaces in the path names for the directories.

Re: Negatron.ini

Posted: Mon Aug 20, 2018 11:25 pm
by BabelSoft
Sorry for the late reply, I was in vacation.

I'm pretty sure that spaces aren't an issue for Extras and Multimedia as I have spaces in the paths I used on my local computer. And I don't see why this would be an issue just for the path to MAME but I'll try to reproduce your bug nonetheless.

Seeing the example you gave me, I suppose your on Windows.

But really, it should work without having to put quotation around paths in Negatron.ini.

Re: Negatron.ini

Posted: Sun Aug 26, 2018 9:48 am
by BabelSoft
I tried to put spaces everywhere and launch a fresh install of Negatron.
Effectively, the very first launch shows you the initial set-up dialogue box, and then it crashes. But if you relaunch it a 2nd time right away, everything will run fine and Negatron will use the set-up configured during the 1st launch. Any subsequent launches works as well without issues.

Really a weird bug but I'll fix it for the next version :)

Can you confirm that this is what you see on your side? If not, please tell me what OS you're using. I only tested on Windows 10 64-bit.