Page 1 of 1

Negatron.ini is missing - Error

Posted: Fri May 08, 2020 7:43 pm
by Viking245
Just found this program this morning and it is simply amazing! Thank you so much!!

However.... When I ran it the 1st time, I entered in the path to mame64.exe. It loaded, went through the gathering information process. And everything looks and works fantastic! Without making any [other] configuration changes, I exited the program ("X" in the upper right hand corner), later go to restart it and get an Error:

Code: Select all

An unexpected error occurred while reading configuration file:

java.lang.ArrayIndexOutOfBoundsException: Index 1 out of bounds for length 1

The file Negatron.ini is missing or is badly formatted.
If Negatron.ini isn't missing, please edit it, or delete it for
Negatron to launch the configuration wizard during next launch.
I attempted restart several times, getting the same error. Deleted the ini file and restarted (re-entered the path to mame64.exe) with no issues. Fortunately it didn't need to rebuild its' cache files. And all was good. Until attempting to restart the program.

The ini file I'm sure is fine, but here it is:

Code: Select all

mame                      D:\MAME\MAME_SWL\mame64.exe
mameini                   D:\MAME\MAME_SWL\mame.ini


vlc                       D:\MAME\Negatron\app\vlc\libvlc.dll
language                  en-GB
infotipTiming             aggressive
cheatmenu                 0
vsync                     none
fontSize                  0.0
sound                     1
video                     1
view3d                    0
Using Windows 10 (up to date)
(per "About Java" I have v8 (1.8.0_191-b12))
Downloaded (and unblocked)
Extracted all files to a temp folder and ran Negatron-0.100.1.msi
Installed to my D drive (no admin restrictions)
I did not install Java v11 or later because the All-in-one pack indicated v14.0.1 portable was included.

I started towards downloading/installing Java 14 and stopped when it said I needed t create a login. (Not that big of a deal, but it's just one more thing :roll: .) This is also when I saw v14.0.1 portable was included with the installer.

Is there something I overlooked that may be causing this error? Maybe a conflict between v8 and v14? Do I still need to install v11 or later? Any help would be greatly appreciated. Thank you. :)

Re: Negatron.ini is missing - Error

Posted: Sat May 09, 2020 6:32 am
by BabelSoft
Indeed, you don't need to install Java 11 or 14 with the Windows pack. You can keep your system-wide Java 8, Negatron simply uses its embedded version of Java 14.

It doesn't work at restart because the entry chdman (6th line in negatron.ini) is empty, probably because Negatron couldn't find it automatically in your MAME folder. Which version of MAME and which MAME derivative do you use? Negatron expects MAME to come with chdman.exe but it seems like your version of MAME doesn't have it.

I can modify Negatron so that it doesn't crash when chdman.exe is missing but I need to understand why you don't have it before.

Re: Negatron.ini is missing - Error

Posted: Sat May 09, 2020 2:46 pm
by Viking245
That did indeed resolved the issue. Thank you!

The MAME release is 0.220, a derivative of my own compile.

I started learning C# about 10 months ago and one of the projects I made was a MAME GUI compiler, start-to-finish (download and/or update MSYS2, download current/previous [select-able] release from GitHub, compile, copy files). This was a personal just-for-fun [learning] project and.. well.. I thought how cool is that I am able to compile my own program... from within my own program. :)

Short story long... in the last "Copy" phase, I have a Copy_Compiled_Files_button and a Copy_Without_Tools_button. I didn't copy the Tools over [to my working directory].

Though I've learned a lot so far about MAME and all it can actually do (custom cfg's and ini's, Software Lists...), I'm slowly but surely expanding towards Lua scripting and making use of the Tools. Baby steps. And I'm sure this is just the tip of the iceberg. My main thing lately has been a plugin I made for a frontend to import Software Lists. Again, just-for-fun. Learned a lot about parsing xml's :D. I figured since I've helped everyone to be able to import these, maybe I should figure out how to get them to run as well. I've done fairly well so far, but I'm thinking Negatron will help push me to the next level (which right now is learning about the different exp(ansion) slots available for various machines). srry... long story got longer...

Re: Negatron.ini is missing - Error

Posted: Sat May 09, 2020 3:41 pm
by BabelSoft
I see, so it's just you getting around the inner working of MAME. Well, it's really not a common use case so I won't fix this.
Chdman.exe is really the main tool to know about as soon as you start playing around with softlist, HDD and CD images. Enjoy your programming discoveries!

Re: Negatron.ini is missing - Error

Posted: Sat May 09, 2020 5:38 pm
by Viking245
Thank you very much! It's been a lot of fun thus far!